• Technical Help

Viewer Support

Welcome to the Viewer Support Center. Here you will find some hints for solving problems you might be experiencing while viewing content.

System Requirements

We recommend the following minimum system requirements in order to enjoy the best possible movie streaming experience.

Most Recent Version of Adobe Flash

*Download here

For Windows XP Users

  • 32/64-bit Windows XP SP2 with all current updates applied
  • Pentium III processor or better
  • At least 512MB of RAM (1GB or more recommended)

For Windows Vista Users

  • Any 32/64-bit version of Windows Vista with all current updates applied
  • Pentium IV processor or better
  • At least 1GB of RAM (1.5GB or more recommended)

For Mac OS X Users

  • Mac OS X 10.4 (Tiger) or above
  • At least 512MB of RAM (1GB or more recommended)
  • G4processor or higher

Other Requirements

  • Internet Explorer 6 or higher or Firefox/Mozilla 1.5 or higher

  • Broadband/high speed Internet connection (DSL or Cable) with a download speed of at least 800kbps (higher download speeds are required for higher bitrate content). You can check your speed here: www.speedtest.net
  • Adobe Flash Player: http://get.adobe.com/flashplayer/

Browser Settings

JavaScript must be enabled. There are different steps depending on your browser of choice:

Internet Explorer

  • Choose Internet Options from the Tools dropdown menu
  • Click Security
  • Click the Custom Level button
  • Scroll down and click the Enable button under Active Scripting and Scripting of Java Applets
  • Click OK and then Yes again on any confirmation prompts
  • Click OK
  • You may need to restart Internet Explorer

Firefox

  • Choose Options from the Tools menu
  • Click the Content button
  • Check the box next to Enable JavaScript
  • Click OK
  • Restart Firefox

Safari

  • Choose Preferences from the Safari menu
  • Click the Security button
  • Check the box next to Enable JavaScript
  • Close the Preferences window
  • Reload the page

Chrome

  • Make sure Adobe Flash Player is up to date
  • Make sure the browser is set to allow plug ins